« Feedzirra - A Ruby feed library built for speed | Main | Feedzirra gets a few more features »

February 13, 2009


Alex MacCaw

I like it :)

Jason Adams

I like it! Calling entry.sanitized.foo does exactly what you'd expect it to -- I don't see how you could get any clearer than that.

Luke Melia

I'm on the fence.

It kind of looks like a LoD violation at first glance. And another route not in the gist is to offer entry.sanitized_title (implemented perhaps via method missing).

OTOH, I like that you could provide a collaborator (like a view renderer) with the result of entry.sanitized and then it has no way to do the wrong thing.

James Adam

I tried to trackback, but it always seemed like spam:



No, I don't like it. You better stick woith the convention of zooming in on specifics left to right, similar to

entry = feed.entries.first


santitized_content = entry.author.santitized
Gabe Hollombe

Like a few others, I prefer:


John Nunemaker

Interesting but I think entry.title.sanitized is better. You could just add a method to string to cover all or extend the functionality on the specific returns. Just a thought.

Peter Jaros

Oh, that is beautiful. I'm not sure in this particular case whether I like entry.sanitized.title or entry.title.sanitized better. However, once you've decided you want a proxy object, the use of Class.new is brilliant. I needed this idom badly a year ago when I wrote Rubot, which is a DSL for behavior-based robots. I actually named a class BehaviorFactoryBuilder. How sad is that?


(Man, I've improved a lot in the last year.) :)


Vimax pills are created by a professional team of doctors who have many years of experience, working to achieve the best penis enlargement pills on the market.

The comments to this entry are closed.

My Photo



Twitter / pauldix